Browse forums 
Ankama Trackers

Mutilation power buff goes away after 1 turn and Flying sword doesn't heal me

By LazMimar#3352 - SUBSCRIBER - April 10, 2020, 08:42:11

Mutilation spell's tooltip says it gives 150 power(infinite) to me since it is level 2, and in the fight chat, it says 150 power (1 turn) and the next turn when the spell is still active, it takes my hp as usual but doesn't give the power buff. I don't think it is just a visual bug because I don't see it on my characteristic page/advanced states or I don't see it on my states (where you click yourself on the timeline in the fight and see what buffs you currently have)

But weirdly I tried it with a 200 level sacrier and it says 200 power (infinite) on their states. 

Is that a translation error on the spell's tooltip where you only get power for one turn if the spell is level 1 or 2 (10 and 77 levels) and goes infinite at 144 or a bug? 


edit: I just realized, flying sword is not healing me, even though spell tooltip says it heals the summoner. 
5 0
Reactions 2
Score : 29
Yes. Just reach lvl 77 in Jahash and saw this too. The Mutilation  is bugged only in lvl 2. Lvl 1 & 3 seems to be working just fine. The spell description says that you lose life to gain power as long the skill is active but in lvl 2 the power is applied only in the turn you activate it.

The healing of flying sword lvl 1 seems to be working just fine with sacrifice lvl 1. Maybe in greater levels It is bugged too.

Hope to get fixed asap.
2 0
Score : 1
Just noticed this too, but i thought it had something to do with the mobs i was fighting. So i went back to Astrub and tried it on some piwis and had the same problem. Really hope this gets fixed soon, I miss the power buff.

Same goes to say about the sword. It just doesn't heal me ever since it reached lvl 2.

Really hope the devs get on this.
0 0
Respond to this thread