Browse forums 
Ankama Trackers

Can't access Crocuzko even though "Lost in Time" quest is completed

By Chechongo#7915 - SUBSCRIBER - January 30, 2023, 20:36:35
I completed the "Lost in Time" quest with my Feca Kaizokuou on Ilyazelle  a couple of months ago. I don't really remember if I went to Crocuzko then but I tried to go now through the zaap and it says it's "undiscovered". According to other forum posts and the wiki, I should be able to go there, so I don't know why I can't.

I've tried to go through the zaap in Astrub, talked to the croco besides in and nothing. I don't know why I don't have the zaap saved. I don't know if it's because the server merge caused some kind of bug or something different, or maybe it's that I'm not supposed to go there yet even though I completed the quest that apparently lets me in.
1 0
Reactions 1

Can you confirm that the Lost in Time quest still shows up as complete in your log? If it is, you should normally have access to the zaap. If I'm not mistaken, the NPC that gives you this quest, Crokalcrolak, should not be in Astrub after the quest is complete, so you should not be able to talk to him there anymore. What happens when you interact with him?

Thanks in advance.
Respond to this thread