Browse forums 
Ankama Trackers

Linux - New installation Method

By [Manaia] - ADMIN - September 21, 2018, 11:55:30
Reactions 34
Score : 1
Hi, I had the same issue like krazunia.

Spoiler (click here to show spoiler)

0009:err:seh:start_debugger Couldn't start debugger ("winedbg --auto 8 116") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
but i resolved this issue with this tutorial:
0 0
Score : 1
Did anyone ever figure out how to get this running? It's completely borked for me.
0 0
Score : 181
Since wine was updated to version 5.0, Dofus is not working anymore. So you have to install and use "playonlinux", which is a frontend to administrate different wine-versions concurrently. 

A tutorial on what to do is here:

Remember to choose wine version 4.19, otherwise Dofus won't run.
1 0
Score : 3
I have a problem downloading dofus after repair How can I download now
0 0
Score : 90
It might help some of you, so:

I didn't manage to install dofus via the image Ankama Launcher-Setup-x86_64.AppImage on linux.

Indeed, when executing the file Ankama Launcher-Setup-x86_64.AppImage after having applied the execution right,"chmod +x Ankama\ Launcher-Setup-x86_64.AppImage", a window was launched with kind of circles rotating, but will get stuck indefinitely to this animation and never launched the game installation.

So, what has worked for me:
*Download the version of the game  for Windows "in 32 bits, compatible with 64 bits" provided by the support at the address:

*It allowed me to retrieve a file called
Then, I unzipped  this file with the command
*Then, I launched the command "wine Dofus.exe"

And miracle, it worked!!!!

Be aware to the windows version that wine exploits.
Check that wine exploits  a windows version > windows 7 thanks to the command winecfg.
This command will launch a window allowing you to handle the windows version exploited by wine.
If the windows version is <= windows 7, modify it to windows 8 or windows 10.

About the wine version that I used:
When I execute the command "wine --version", I get the result "wine-5.0"

0 0
Score : 129
The 32 bits version was crashing all the time for me (it crashes because of memory usage problems). Solved using the 64 bits version, with the latest wine-staging:

I would definately recommend to avoid the 32 bits version.
0 0
Score : 444
Anyone get this to work with Steam OS and Proton vs Wine ?
1 0
Score : 120
the ONLY way to run the game currently (after Ankama removed the ability to directly launch the .exe file) is by using the script from Github
0 0
Score : 1
What is the situation with new version of wine ?
I can't get it working on Ubuntu 22.04, wine latest stable version.
Same problem 32/64bits of dofus.
Launcher ok but the game doesn't show up
Here is cmd output :

ALSA lib pcm_dmix.c:1032sadsnd_pcm_dmix_open) unable to open slave
0258:fixme:sync:SetWaitableTimerEx (0000000000000184, 0000000001E5FBD0, 0, 0000000000000000, 0000000000000000, 0000000000000000, 500) semi-stub
022c:fixme:system:EnableNonClientDpiScaling (0000000000060078): stub
022c:fixme:nls:get_dummy_preferred_ui_language (0x8 0x409 000000000011A7D4 0000000000000000 000000000011A7D0) returning a dummy value (current locale)
022c:fixme:nls:get_dummy_preferred_ui_language (0x8 0x409 000000000011A7D4 0000000003754C20 000000000011A7D0) returning a dummy value (current locale)
022c:fixme:secur32:LsaGetLogonSessionData 000000000011D4D8 000000000011D4C8 semi-stub
022c:fixme:file:server_get_file_info Unsupported info class 12
022c:fixme:mmdevapi:control_RegisterAudioSessionNotification (00000000007FBEB0)->(0000000001B9D230) - stub
022c:fixme:mmdevapi:control_UnregisterAudioSessionNotification (00000000007FBEB0)->(0000000001B9D230) - stub
0278:fixme:secur32:get_cipher_algid unknown algorithm 23
0278:fixme:secur32:get_mac_algid unknown algorithm 200, cipher 23
0278:fixme:secur32:get_cipher_algid unknown algorithm 23
0278:fixme:secur32:get_mac_algid unknown algorithm 200, cipher 23
022c:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
022c:fixme:dxgibiggrinXGID3D10CreateDevice Ignoring flags 0x820.
022c:fixme:d3d11:d3d11_multithread_SetMultithreadProtected iface 000000000071FE50, enable 0x1 stub!
027c:fixme:d3d:state_linepattern_w Setting line patterns is not supported in OpenGL core contexts.

Which version of Wine do we need to use ?
0 0
Score : 1

Spoiler (click here to show spoiler)

0 0
Respond to this thread