FR EN DE ES IT PT
Browse forums 
Ankama Trackers

Game wont start in launcher linux

By gangmem - SUBSCRIBER - December 21, 2019, 12:57:15

Hello

I have install 64bit dofus applimage and install the launcher. Now the game have downloaded true the launcher but when i press play the game wont open.

1 0
Reply
Reactions 10
Score : 62

Check the folder installation of Dofus, which it should be in ~/.config/Ankama/dofus or if you installed the game on a different directory go to that directory and there should be a file called zaap-start.sh , open that file with a text editor and it should have these lines (if you don't have the file, you can create it and name it zaap-start.sh):

#!/bin/sh
wine Dofus.exe --port=$ZAAP_PORT --gameName=$ZAAP_GAME --gameRelease=$ZAAP_RELEASE --instanceId=$ZAAP_INSTANCE_ID --hash=$ZAAP_HASH --canLogin=$ZAAP_CAN_AUTH
exit $?


As you can see basically the Linux version of Dofus is the same Windows version running with wine, make sure you have WineHQ downloaded

https://tecadmin.net/install-wine-on-ubuntu/
https://www.winehq.org/

There you have it, once you meet those requirements, the game should start when you press the Play button.

I also  recommend to use PlayOnLinux to create a specific wine prefix just for dofus with custom configuration to optimize some interface aspects (fonts, accents) and to just use that specific wineprefix with dofus which I think it should be have better long lasting performance than using the systemwide Wine.
 

1 0
Reply
Score : 371

Hallo

Im stuck with selecting dofus.exe  , The file is in hidden folder, i only can select if i use file manager. When i use the wine to select it wont show the folder that i need.

Is there a option in playonlinux to see and select hidden folders?

0 0
Score : 371

Hello,

The folder was correct and and t zaap-start.sh  was correct to.

I dint had wine intsalled. I have new problem game load till 56 percent and wont load full.



 
0 0
Reply
Score : 62

This seems to be a wine problem instead of a Dofus Problem, I recommend to download PlayOnLinux to run Dofus on a specific Wine just created for the game, if you want to do that, download PlayOnLinux, go to "Tools" and "Manage Wine Versions", install a 32 bits version of wine (I recommend the staging one), if you have any problem downloading the wine versions available via PlayOnLinux, go to  https://www.playonlinux.com/wine/ and download manually your prefered version and extract the .tar.gz on ~/.PlayOnLinux/wine/linux-x86

Once you download the 32 bits version of wine for PlayOnlinux , go to the left panel of PlayOnlinux and click on "Install a Program" :
Then choose "Install a non listed program" :
Then, the PalyOnLinux new manually installation program will start, choose to install the program on a new virtual unit:
Then, choose the name of your virtual unit:
Then, click on "Use another Wine version" and "Configure Wine":
Then, choose the wine version you've downloaded:
And select "32-bits windows installation" :
Then, the wine prefix will be created and the configuration window will appear, customize your wine if you want to (better interface themes available, another font, colors, etc) and then, the PlayOnLinux wizard will ask for the executable that's gonna work as the installer of the programm you want to run in this virtual unit, basically this unit is just for Dofus, since you don't want to install Dofus again, you just want to run the game in this specific wine prefix, choose the executable of dofus, Dofus.exe, which it should be in ~/.config/Ankama/zaap/dofus or in the directory you installed dofus :
Then, PlayOnLinux will launch Dofus (it starts with some errors cuz it was launched without the launcher), just close it and then, PlayOnLinux will ask if you want to create a Desktop Shortcut to the .exe program "installed" in this unit, just click on "Explore" and choose Dofus.exe:
The wizard will ask for the name of the shorcut and then it will create the shortcut on the desktop, after that, is gonna ask if you want to create another shortcut, just close the wizard and if you go to your desktop, you should have the Dofus shortcut:
Open the shortcut (.desktop file) with a text editor and copy the line Exec:
That's the command that opens the programm (Dofus.exe) on the specific wine prefix created for it, now you want the Ankama Launcher to launch Dofus on that wineprefix instead of the normal wine, to do that, go to the Dofus folder installation ~/.config/Ankama/zaap/dofus and open the file zaap-start.sh with a text editor, it normally looks like this:
But, since we want the Launcher to Launch Dofus on the wineprefix created for it, change the part "wine Dofus.exe" for the exact command we copied from the shortcut on the desktop, to make it like this:
There you have it, save the changes, delete the Dofus shortcut on the desktop and now, every time you click "Play" on the Ankama Launcher, it will launch Dofus on the specific wineprefix created exclusively for Dofus.

The file zaap-start.sh can restore to its original state after some big updates or if Dofus gets corrupted and you have to repair it via Launcher, so make sure to change the file whenever it's necessary, if you forget what is the command of the executable, you can always create the shortcut again with PlayOnLinux, just go to "Configure", select your virtual unit and there's some options to this virtual unit, like create new shorcuts, install libraries or components on the virtual unit, etc, I recommend to install the "FontSmoothRGB", "RegisterFonts" components to get all the fonts on your system in the wine virtual unit and to make fonts look smoother:
That should be all, as you can see , Dofus runs perfectly every time you click on "Play" via launcher:

PS:
There's an optional thing you can do with something that happens on Linux with Dofus, which is the fonts not being displayed correctly (bold or normal) in the chat or in the omega Levels which is not a big thing, but certainly bothers some people like me, to fix this, install a custom interface theme on Dofus, you can find some in https://www.dofus.com/fr/forum/1578-themes-interfaces
After you install the Dofus interface theme, go to the theme's directory, it should be in ~/.PlayOnLinux/wineprefix/%Name of your virtual unit%/drive_c/users/%Your user%/Application Data/Dofus/ui/themes/%Your downloaded theme% , there's some folders on the directory, but we only will edit some files in the css folder:
Open all the files with a text editor and change all the ocurrences of the font Tahoma (which is the one that has conflicts) for a preferred one , I chose Open Sans because is the only one that works for me in Dofus and displays everything as it should, if you don't have that font or if you prefer another one, you're free to go, download and install some fonts.
In addition, after you change all the font-family: Tahoma; for font-family: Open Sans; in the files, add this line just to these 2 files chat.css and chat_input.css:
useEmbedFonts: false;

the file should look like this:
Now save the changes, choose the theme with Dofus and when you play , you will notice the differences between the new font that displays the game-players with bold font , the taggings, and everything would look better than the normal one, it seems to be a problem with the Microsoft's fonts renderization on Linux.

Everytime there's an update on the theme you have to repeat the process, but if you're as bothered as me to not see the fonts displayed correctly is gonna worth the edition of the files, is not that hard once you get it.

I know this tutorial is long but I want to make sure everyone who plays Dofus in Linux enjoys the game and have the same experience or even better (I think Dofus has better performance on Linux) than the people who plays on Windows or Mac.

 
2 0
Score : 18

Ankama Launcher & Dofus were working fine for me although this past week I cannot get past 56% same as the previous post image. My system specifications are:

- Manjaro Linux
- Kernel: Linux 5.4.6-2
- wine-5.0-rc2 (Staging)

Hope this helps.

After looking at the zaap-start.sh file as suggested, I thought it might be useful to try different wine versions. I used Lutris as opposed to PlayOnLinux but both the same:

- 4.19 works (thank you for suggesting this one)
- 4.20 crashes at 56%
- 4.21 also crashes
- 5 was my original failing one

It would appear something changed between 4.19 and 4.20 that causes Dofus to fail...At any rate my game is working after downloading "lutris-nofshack-4.19" and ending up with a zaap-start.sh looking like:

/home/user/.local/share/lutris/runners/wine/lutris-nofshack-4.19-x86_64/bin/wine Dofus.exe

Hope they can pinpoint the issue.

Apparently my update post was merged with my last one...wine 4.19 works well, thought the 4.20 changelog could be of use to Ankama to find the issue?

https://www.winehq.org/announce/4.20

0 0
Reply
Score : 62

For me it works perfectly but I don't use the normal Wine, I use the PlayOnLinux and a specific wineprefix just for Dofus and it works like a charm, to do that, go to the previous comment, there's some sort of tutorial, I have had so much trouble with the systemwide Wine so I changed for PlayOnLinux's and I've never had  any problem.

1 0
Score : 371

I finally got it to work. Thanks evry one who help me/us

0 0
Reply
Respond to this thread