Browse forums 
Ankama Trackers

"downloading package 7z" stucked.

By 890birth#7750 - SUBSCRIBER - April 03, 2020, 09:51:52

As I woke up this morning, the launcher stuck at the 'clock' loading screen for ages. Then as the simple solution for most of the launcher problem, I restarted the launcher and nothing works.

So I decided to uninstall the launcher, which leads me to the next problem. The Ankama Launcher setup stuck halfway through the 'downloading package 7z', for hours now. I figured out it might be a problem with my laptop instead, so I formatted this laptop (windows), proceed to download Dofus again and Walla, same problem again. 

'Installing ... Please wait ... Downloading package 7z  [|||||||||||||||||||||||||                                                               ]  (stucked, for hours)

Its the 3rd Day of Temporis, Im doing fine with progress, until now. Good game

edit: also tried the TLS 1.2 Solution, it is already turned on for my laptop. Anyway, I deactivate it, activate it again. The same problem occured. Nothing seems to work currently. 

Additional information: 8 hours after trying, I get another laptop. With the same setting (TLS 1.2 activated). 

Try to download the launcher on the new laptop, same problem too. The green bar stucks at the same spot as my laptop. 

I also tried with various connection. Would be great is assistance comes. 

0 0
Reactions 3
Score : 1

I have the same problem too. Someone help please 

0 0

What operating system are you using?


  • Have you tried changing your Internet protocol to TLS 1.2 (Control Panel/Internet Options/Advanced Tab/Security section: "USE TLS 1.2")?
  • Please check your system and graphics card drivers for updates.
Respond to this thread