FR EN DE ES IT PT
Browse forums 
Ankama Trackers

Installation Problem - "Unexpected Publisher ID"

By Aave-Sanguinarius April 18, 2013, 04:24:31

Hi there!

I forgot my account information for a while and finally managed to remember/recover it, but while attempting to re-install Dofus to my computer, I ran across a bit of a problem after I had updated everything. When I went to finally play the game, this popped up:



I've uninstalled and re-installed the game and Adobe AIR two or three times now, hoping that perhaps it was just a glitch. Unfortunately, that hasn't been the case. Are there any suggestions for what I can do to resolve this? I'm working on a Mac, OSX Ver. 10.7.5. I'd greatly appreciate any help!

0 0
Reply
Reactions 2
Score : 182

The same message also popped up when I was trying to log my account after downloading the updates.
I also uninstalled and re-installed Adobe air and Dofus. It did not work, the same message popped up.
Then I tried an older version of Adobe Air, only resulting in a message popping up that the correct version of Adobe Air could not be found.

I have seen other forums post with similar problems, most from MAC users.

Currently I am on a French archived version of Dofus.
There is no uplauncher showing up when I load the game, no sound and I am not able to change the language.
For me, not familiar with the French language, doing the quests and trading markets have become quite a challenge ><

Information on solutions for this Adobe Air problem would be appreciated.

I just found a forum post with a possible solution. It worked for me, the following information was a big help biggrinDD

Click here


Marwen on Imps Village posted this possible fix for the Mac error when patching the beta (thanks Marwen!) I had this error on my Mac computer (10.7.5), tried it, and it worked, so I'm sharing it with you.

If you're comfortable with using the Terminal, this line is all you need:

rm "/Applications/DofusBeta.app/Contents/Resources/Dofus.app/Contents/Resources/META-INF/AIR/publisherid"

If you're not that comfortable with Terminal, here's the steps:

Go to your Applications folder.Command-click on your Dofus Beta application and choose "Show Package Contents"In the window that appears, open the Contents folderOpen the Resources folderYou will now see two items. Command-click on application called Dofus (yes, it gets a little recursive) and select "Show Package Contents".Open the second Contents folderOpen the second Resources folderOpen the META-INF folderLook for a file named "publisherid" and delete that fileRun the DOFUS Beta application.This may not fix every Mac user's problem, but it seems to be non-destructive and it has worked for some.

I've reported this problem to the devs as well, so hopefully there will be an official fix soon.

UPDATE: For those who are having the disappearing "Play" button issue, make sure you are running only the beta client - the normal DOFUS client must be closed before opening the beta on your system. Once again, all praise and love for this tip goes to Marwen, who is awesome. =)
 

0 0
Reply
Score : 754

Thought I was doomed with this PoS mac but this worked, thanks!!!

0 0
Reply
Respond to this thread