FR EN DE ES IT PT
Naviguer dans les forums 
Trackers Ankama

Mon retour sur la (nouvelle) version Linux

Par TheAquazus - ABONNÉ - 02 Octobre 2018 - 07:16:57

Bonjour, je me permet de faire un retour sur la version Linux afin d'assister l'équipe de développement.

Voici comment j'ai procéder pour installer le jeu :
1) Installation de Wine version stable via leur répos
2) Installation de libpng
3) Décompression et lancement du launcher

Alors avant toute chose voila les informations sur mon installation et mon ordinateur :

Voici les problèmes que j'ai constaté par ordre de gravité :
- LE CHAT N'A PAS DE FORMATTING. Ni gras, ni italique, c'est très, très, énervant, j'ai vérifié dans les logs et je vois aucune erreur de dépendance...
- Il arrive que le jeu fasse n'importe quoi avec les interfaces, ca m'est arrivé dans mon inventaire et en sortant d'un combat, les interfaces créent des "trous" qui empêchent d'autres interfaces d'apparaître par dessus, assez difficile à expliquer et j'hésiterai pas à filmer si je retombe dessus
- Il arrive que le jeu crash/freeze sans raisons apparentes, j'en ai fait l'expérience deux fois, une fois en cliquant sur le bouton "Sorts" hors combat et une autre fois sans raison particulière, cela reste assez rare.
- Si vous utilisez un VPN ou que vous avez plusieures cartes réseau, vous n'aurez pas de son en jeu ainsi que le message du genre "Lancer dofus sans passer par l'updater n'est pas recommandé..." directement au démarrage du jeu, je pense que cela est du au fonctionnement du Reg qui bind un port pour que le client se connecte dessus
- Les deux warning au démarrage du jeu ainsi qu'à l'ouverture de l'ankabox, bon c'est pas grave...

Si vous avez un bug à corriger, corrigez celui du chat, le reste c'est rare et/ou pas important et n'entravent pas le gameplay <3
Je précise quand même que j'apprécie le travail sur cette version et qu'elle fonctionne vraiment très, très bien mis à part les petites choses mentionnées au dessus.

Je reste disponible pour réaliser des tests avec mon pc principal ou des machines virtuelles, même tester le client beta si nécessaire.

EDIT 1: Je rajoute un dernier truc esthéthique :
Lors de l'ouverture du launcher, on vois encore les bordures natives, il faut réduire puis aggrandir le launcher pour qu'elles disparraissent


EDIT 2:
La dernière mise à jour après la maintenance a cassé le son de mon côté, aucun message d'avertissement sur le fait qu'on utilise pas l'updater, le son ne fonctionne juste plus du tout sad

EDIT 3:
Une réinstallation complète du jeu à régler le soucis de son, je me vois mal faire ça à chaque petite mise à jour par contre
1 0
Réactions 8
Score : 166

Bonjour, je suis débutant sur linux et tu as l'air de savoir de quoi tu parles. Je poste ce message ici pour qu'il profite aux autres néo-linuxiens mais je comprends qu'il aurait peut-être plus sa place en message privé. Bon : J'essaye d'installer libpng en tapant "sudo apt-get install libpng" mais j'ai le message d'erreur :
"E: Unable to locate package libpng"
Je réécris alors "sudo apt-get install libpng" et cette fois ci je fais double tabulation pour voir les propositions. Je me retrouve avec :
"libpng16-16              libpng-dev               libpng++-dev             libpnglite0              libpnglite-dev           libpng-sixlegs-java      libpng-sixlegs-java-doc  libpng-tools"
J'imagine que je devrais choisir "libpng16-16" mais je n'en n'ai pas la certitude ! Je ne sais pas où trouver des informations sur les différences entre tous ces packages...
Il en est plus ou moins de même avec winehq : je ne n'arrive pas à trouver les informations pour lancer l'updater en utilisant winehq. En effet le tuto d'installation winehq me fait installer le package nommé "winehq-stable". Et en tapant "man winehq-stable" ou même "man winehq" je me retrouve avec le message d'erreur :
"No manual entry for winehq-stable" / "No manual entry for winehq"
Désolé si ces question sont embêtantes ^^
Merci d'avance,
LeChatMoqueur

Edit: libpng16-16 était déjà installé sur ma version de linux (Ubuntu Mate 18.0.4) j'ai alors lancé l'installateur mais il freeze lors du téléchargement de l'updater... :/

Edit2: Il ne fallait en fait pas désespéré au 1er freeze. Après 5 ou 6 tentatives d'installation non fructueuses l'installation a finit par fonctionner ! L'updater se lance, le MAJ se télécharge, le raccourci bureau est créé. J'écris cela pendant le téléchargement de la MAJ donc je n'ai pas encore tester en jeu mais je sent que ça fonctionnera.

Edit3: La 1ere session de jeu était parfaite, par contre après avoir fermé l'updater il y a eu une petite fenetre avec la liste de tous les processus qui étaient en train de se fermer un par un et arrivé au dernier ça a freezé. Du coup j'ai fait comme pour l'installation quand ça freezait : j'ai fermé et réouvert ma session et j'ai relancé le jeu. Et là bah... l'updater reste bloqué sur "Recherche de mises à jour".
En lançant "./Dofus.desktop" depuis la console j'ai le message d'erreur suivant :
"./Dofus.desktop: line 1: [Desktop: command not found
wine: cannot find 'C:\\users\\arnaud\\Local\' "

0 0
Score : 166

J'ai trouvé la solution !
Il faut lancer le désinstallateur et choisir l'option "Réparer" au lieu de "Désinstaller", ça marche niquel. Bon le désinstallateur est pas simple à trouver :
"/home/*ton nom linux*/.wine/drive_c/users/*ton nom linux*/Local Settings/Applications Data/Uninstall Dofus.lnk"
*ton nom linux* faisant bien référence à ce nom de dossier sous lequel sont ranger tous les "Documents", "Downloads", "Picutres", etc...

0 0
Score : 1983

Les bugs cités par l'auteur sont toujours présents. Je rajouterai à ceux-ci :

- Effacement du chat sans aucune raison
- Crash/Freeze sans aucune raison de plus en plus fréquents
- Map non chargée qui amène à un crash ou qui donne l'impression d'être à un endroit où on n'est pas

Les crash intervenaient uniquement en changeant de map avant cette version (pour ma part), maintenant les crash interviennent sans même changer de map et potentiellement en plein combat.

(Je suis sur Arch Linux donc la dernière version de Wine)

0 0
Score : 8579

Une "version linux" qui doit passer par Wine pour fonctionner ?

0 0
Score : 1983

Etant donné la technologie utilisée (adobe air) et le non maintient depuis 5 ans de mémoire de cette dernière sous Linux (merci adobe), cela posait des problèmes de sécurité assez sérieux et de possibles non compatibilités de nouvelles fonctions d'adobe air vu qu'il n'est plus mis à jour du tout.

0 0
Score : 8579

Si je me souviens bien ils ont arrêté le support en 2012. Ce que je voulais dire c'est qu'une version "linux" qui doit passer par Wine c'est une version Windows. ph34r

0 0
Score : 1983

En effet mais bon, ils disent que c'est la version Linux, ils l'ont annoncée comme ça donc on va les laisser croire qu'ils supportent Linux. Remonter les bugs en soit ça ne sert pas à grand chose de toute façon, les bugs ne pourront jamais être corrigés sachant que Wine évolue très vite et change pas mal de choses à chaque version et je suppose qu'aucun des développeurs ne teste la version sous Wine.

Un autre problème qui m'est arrivé plusieurs fois :

Lors d'un changement de classe, le jeu freeze lorsque l'on doit choisir notre nouvelle classe.
Heureusement, en essayant une dizaine de fois, le jeu m'a bien laissé choisir ma classe sinon je serais resté bloqué sur cette page sans pouvoir jouer.

Je pense que ce freeze est du à l'animation qui se lance quand les classes apparaissent.

0 0
Réagir à ce sujet