FR EN DE ES IT PT
Naviguer dans les forums 
Trackers Ankama

(CORRIGE) Mise à jour automatique des animations sur plusieurs instances Dofus Rétro 32 bits Mac OS

Par Ushuaiaaa - JAMAIS ABONNÉ - 07 Octobre 2019 - 02:32:27

Hello !
Je lance 8 fenêtres Dofus Rétro 32 bits sur Mac OS  avec 1 logo d'Adobe 10 par instance (soit 8instances/logo dans le Dock).

Gros Problème sur les animations qui ne s'actualisent pas !! 

Est-il normal que les animations s'actualisent pas lorsque je switch d'une fenêtre à l'autre ?
=> Par exemple lorsqu'un Blop invoque un Biblop et passe son tour, le jeu se fige tant que je n'ai pas switché sur les 8 fenêtres pour rafraîchir l'action/animation qui vient de se passer !

Je ne sais pas si vous voyez ce que je veux dire mais c'est très ennuyant... Je cherche désespérément une façon de garder les animations actives lorsque les fenêtres ne sont pas en premier plan. Car J'ai l'impression qu'elles se mettent en veille. 

Merci d'avance pour votre aide ! 

0 0
Réactions 21
Score : 5288

Même problème. Je suis monocompte donc ça va. Mais quand des fois j'ai besoin de prendre le compte d'un pote, c'est la misère et pourtant j'ai que 2 comptes à ce moment là.

On dirait l'époque des téléphones qui ne pouvaient pas faire de multitâche haha

0 0
Score : 3

Up !

0 0
Score : 1

Bonjour, venant de faire la mise à jour de mon macbook pro sous le nouvel OS Catalina, je m'apperçois qu'adobe ne prend plus en compte le jeu.
Est-ce que quelqu'un a une explication, solution, lien de téléchargement?

0 0
Score : 581

Ce matin après la MAJ du launcher (sans avoir rien changé sur mon ordi)

Ha c'est bon les gens ! faut juste cliquer sur « réparer » dans le launcher dofus

0 0
Score : 42
J'ai installé adobe AIR / mis à jour flash mais rien n'y fait. Lorsque j'envoie une flèche explosive et que je passe mon tour. Gros bug en attente des 7 autres perso. Alors je dois switcher sur les 7 autres fenêtres pour visualiser l'action que je viens de faire pour débloquer le tour de jeu des autres mobs / perso. Grosse galère ! :/ 
0 0
Score : 46

Salut, il te suffit d'aller dans le dossier où est installé Dofus Retro, de "Lire les informations" sur l'application Dofus.app et de cocher "Empêcher App Nap" (l'option est décochée par défaut, c'est ce qui entraîne le lag entre les comptes). 

2 0
Score : 5288

Oh je savais même pas. Bien vu

0 0
Score : 2

Des astuces pour ceux qui ont high sierra ? 

0 0
Score : 2
https://www.lifewire.com/control-how-mac-applications-use-app-nap-2260788

j'ai test ce tuto et ça marche pour ceux qui ont high sierra et qui n'arrivent pas à cocher "Empêcher App Nap"

plus aucun lags
0 0
Score : 356

Bonjour, existe -t-il une manière de d'empêcher app nap sur la version 64 bits ?  Je suis sur Mojave et je n'ai pas l'option "app nap" dessus.

0 0
Score : 5288

Pareil je n'ai pas trouvé l'option mais bon je joue mono 95% du temps alors..

0 0
Score : 1

même soucis, bug des animations pour les comptes en arrière plan... injouable... si quelqu'un à une solution j'ai tout essayé

0 0
Score : 90

Je pense avoir trouvé la solution, vous faites clique droit sur votre dofus.app, Afficher le contenu du paquet. Vous allez dans Contents/Resources/app.asar.unpacked/retroclient. Ici vous avez un dofus.app (chez moi le logo est rouge, celui d'adobe flash), sur ce dofus.app vous pouvez faire clique droite, lire information et vous allez pouvoir décocher "Empécher App Nap".

0 0
Score : 54

Bonjour à tous,

Le problème principal est qu'il est impossible de désactiver App Nap lorsque l'on joue en 64 bits (s'il vous plait, si quelqu'un trouve un moyen, partagez le! <3).

Qu'est ce qu'App Nap? C'est un outil sur MacOS qui permet de faire consommer moins d'énergie aux applications que le système considère comme inactives. En soit c'est une super idée, mais sur Dofus cela implique que si vous jouez sur plus d'un compte, tout les comptes qui n'auront pas le focus vont énormément lager (en combat c'est injouable, vous aurez constamment vos personnages "en attente", les cartes ne se chargerons que lorsque le focus reviendra sur les comptes, etc.).

AVANT la mise à jour MacOS Catalina: il était possible de contourner le problème, de jouer en 32 bits et de désactiver App Nap via la méthode citée plus haut (ouvrir le launcher, paramètres, passer le jeu en 32 bits, ouvrir le dossier du jeu, trouver Dofus (pour cela vous aurez besoin de faire des clics droit, afficher le contenu du paquet) et puis une fois trouvé, clic droit puis lire les informations et désactiver App Nap.

APRES la mise à jour MacOS Catalina: Catalina ne permet plus aux utilisateurs d'ouvrir des applications en 32 bits, on est donc forcé à utiliser le 64 bits et il est impossible de désactiver App Nap! Si on joue en multicompte c'est tout simplement injouable.

SVP comment désactiver App Nap sur DOFUS RETRO 64 bits?
Merci!

Ta réponse semble être une bonne solution en théorie mais malheureusement en pratique le problème n'est pas résolu sous Catalina malheureusement  <_

0 0
Score : 59

Surement en bidouillant dans le terminal comme j'ai fais pour ne plus lag avec high sierra 

perso j'ai rentré cette commande :
defaults write NSGlobalDomain NSAppSleepDisabled -bool YES

commande pour réactiver : defaults write NSGlobalDomain NSAppSleepDisabled -bool NO

1 0
Score : 2

up ! :p

0 0
Score : 8183

Salut,

Tu as lu toutes les astuces mises à disposition avant de up ? Sinon ce serait sympa d’exposer le problème plus précisément...

0 0
Score : 1

Hello, j'ai exactement le même soucis !! 4 bureaux, 4 fenêtres dofus et tout se fige quand c'est pas la fenêtre principale ! Pourtant App Nat est bien coché... J'suis sous Mac Os Catalina 64 bits !

HELP ! 

0 0
Score : 66

Hello, je suis sur El capitan, j'ai le même problème, il ne semble pas y avoir "nap app" donc je ne sais pas pourquoi les animations ne s'actualisent pas... Help ! 

0 0
Réagir à ce sujet